实时搜索: jdk1.7有几个版本

jdk1.7有几个版本

825条评论 3153人喜欢 3145次阅读 283人点赞
jdk的版本与netbeans版本之间有什么关系?
netbeans8.x是不支持jdk1.7以下的,请问什么版本支持jdk1.6? , android开发,Eclipse之前用过JDK1.8,bug很多,但是现在androidstudio最新版要JDK1.8才能运行,这种情况怎么解决?我想的是直接安装两个版本jdk,eclipse用1.7的,androidstudio用1.8的?具体应该怎么设置? , sdk api28 不合适,低版本的那个行? , 环境变量配置后用cmd输入javac测试正常。
JDK版本为1.8.0_31,eclipse版本为eclipse-jee-l...

jdk的版本与netbeans版本之间有什么关系? netbeans8.x是不支持jdk1.7以下的,:   安装和运行 PHP、Ruby、C/C++ 这些 NetBeans 包时需要 Java 6 或 Java 5。您可以下载java.com 上最新的 Java 版本。
  安装和运行 Java SE、Java、All 这些 NetBeans 包时需要 JDK 6 或 JDK 5。 您可以下载单独的 JDK 或者下载最新的 JDK 和 NetBeans IDE Java SE 安装包。

jdk1.7开发的java程序能在jdk1.6下面运行吗: 不能 不管多简单的类 就是hello world也是不行的 我试过的 开发人员都是用低版本开发 高版本兼容低版本

AndroidStudio最新版必须使用JDK1.8,Eclipse只支持jdk1.7怎么办?: 在配置文件中把java指向不通的java_home下面就可以的
以win7下的android studio为例
C:\Users\用户名\.AndroidStudio1.8\config\options\jdk.table.xml

stanford nlp jdk1.7是哪个版本: 分词: StanfordTokenizer
词性标注: StanfordPOSTagger
命名实体识别: StanfordNERTagger
句法分析: StanfordParser
依存句法分析: StanfordDependencyParser, StanfordNeuralDependencyParser

我的jdk是1.7.0_07版本的要下载什么版本的tomcat啊?:

下载tomcat6就可以。

Android开发环境搭建:jdk版本为1.7,sdk 版本选择哪个合适?: 现在android开发,都是使用android studio这个官方提供的IDE,它有自带的jdk的,目前官方默认自带的jdk版本是1.7的,存储在你的android studio安装目录下的jre目录,你可以在android studio操作界面 File-->Project Structure 打开操作界面,SDK Location就能看到JDK location了,也可以在这里进行修改。
其实使用jdk1.7 和1.8的区别,仅仅在于你的java代码编写方面,1.8的版本,支持一些更简洁的语法表达式,从某种意义上来说,这只是程序语言的进化而已。就好比最早的程序,使用10101010,但实现一个功能,可能需要写N多的101010,于是出了编程语言,比如C,C++,用几行英文单词来释义,就大大减少了工作量,然后在c++的基础上,诞生了java,剔除了繁杂的指针问题,再到现在主流的python,以前c++,java代码10行才能实现的功能,python可能只需要1-2行代码就可以实现了,这就是编程语言的进化
对应的sdk版本,sdk,其实指的是android操作系统的版本,从最早的1.0beta版本到现在的9.0版本,有相当多的变化,目前市面上90%以上的android手机,操作系统都在4.x以上,也就是说,你的程序支持最低的版本,在API 16以上,即可以兼容几乎所有的手机,而target版本,设定在API 25,26即可,最新的API 28,对应的操作系统也就是android9.0,目前还在测试阶段,2018-07-02发布的,不建议把target设置为最新版本

启动eclipse时出现Fail to load the JNI share library"D:\jdk1.7.0\\bin\..\jre\bin\client\jvm.dll".: 首先 Javac.exe 和 Java.exe 不是一回事,我们在用 JavaC.exe 是在编译程序,而 Java.exe 是在运行程序,我们在使用 eclipse 时是在运行程序,Eclipse 自己本身也是 Java 程序,它启动运行就是我们在运行一个 Java ,而当 Eclipse 启动之后它还需要编译一个程序,不过 Eclipse 自己是自带编译器的,因此它只需要 JRE 而不依赖 JDK, JDK = JRE + 编译调试等开发工具。

因此我们需要测试的是:

C:\> Java.exe -version 这么写的。

从你的说明中看它说 bin\..\jre\bin\client\jvm.dll 这个文件无法加载,我们用眼睛确认一下这个文件是否存在。

另外你提到了你的 JDK 1.8 的但错误消息中提示你 JDK 1.7 的文件没找到,所以当我们机器上有多 JDK/JRE 存在时,我们还需要解决 ”为什么不是用到我的 JDK 1.8 而是 JDK 1.7" 的问题。

最常见的也是我在百度知道中碰到新手问的最多的多个 JRE 存在时出错的情况是当我们还安装了 Oracle 时它帮我们把它自带的 JRE 放到了环境变量 PATH 的最前面,遮挡了我们独立安装的 JDK/JRE。

看这个文章:

https://www.eclipse.org/forums/index.php/t/198527/
和这个:
http://wiki.eclipse.org/Eclipse.ini

我电脑上目前的jdk是1.6 的如果我换成了1.7对已有的项目有什么影响吗?: 一般来说没影响,但是高版本的JDK编译的项目只能在高版本的jre上运行
不过eclipse的编译器可以设置编译版本 也就是你装的是1.7照样成输出成1.6

  • 1.5米的床多少钱

    农行信用卡(贷记卡)密码忘了,怎么办?: 需要致电农行信用卡客服中心4006695599办理密码重置。...

    516条评论 5964人喜欢 3601次阅读 617人点赞
  • 2017年5月12日什么日

    淮安市淮阴工学院北京路校区有哪些公交车到?: 淮安市淮阴工学院北京路校区:6路;8路;12路;26路;28路;32路;48路;游2路,均可以到达。 ...

    720条评论 1026人喜欢 2948次阅读 301人点赞
  • 140公里要多久

    珂润水乳用完会长脂肪粒吗?: 这个很难说啊,我只能说你尽量预防吧预防脂肪粒主要是不要用太油腻的护肤品尤其是眼周容易干燥,应该要用清爽补水的至于脂肪粒,建议可以用 图加兰眼霜涂上能加快脂肪粒成熟脱落,也不留痕迹所以不用太担心啦 ...

    391条评论 5842人喜欢 4061次阅读 956人点赞
  • gd的女朋友是谁

    这个信用卡额度负-50是什么意思: 5000以用完还多花了50元 ...

    879条评论 2570人喜欢 5657次阅读 396人点赞